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Creating Web Pages with Netscape Composer

Introduction

Netscape Composer, part of the Netscape Communicator program suite, is a
simple yet powerful program for creating web pages. Composer works mainly in
a WYSIWYG (What You See Is What You Get) environment, allowing the
designer to create pages easily. While Composer is not as comprehensive a
program as Frontpage, it is an excellent program for the beginning to mid-level
designer and a handy tool for those more skilled.

Composer lets you create pages like you're working with a word processor.  In
fact, you can use normal word processors from notepad to MSWord 97* in
conjunction with Composer to create pages.

*See also the document:
Creating Web Pages with Word 97

Goals

This guide is intended to introduce the following skills:
• Starting a new web page with Composer.
• Using Composer to open, maintain, and save existing pages (including those

created with other programs)
• (taking an existing page and dressing up with composer)
• Related skills:

• Inserting graphics
• Formatting backgrounds
• Importing Text
• Formatting Text
• Inserting standard web elements (Horizontal Rules, etc.)
• Creating links
• Overview of tables

• Saving page to Oakton's server

Related Documents
Included with this guide are several related documents that may be helpful:
• FTP'ing with Netscape
• Understanding Relative and Absolute URL's
• Oakton Web Page Standards
• Setting Up Tables
• Saving Pages to Oakton's Servers
• Word 97 and Web Pages
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Quick Lesson: Web Pages vs. Text Documents

In the background

Behind every web page is a simple text, or ASCI, document that happens to have
codes inserted within the text. By just adding the following codes…
<html><head><title></title></head><body></body></html>
…into a text document (plus saving it with the extension .htm) you can make it
readable on a web browser. It may be boring and static, but it will be readable.

Add a few more codes and you can tell a web browser to display the text in
certain ways (bold, centered, etc.), to insert a picture in a certain place, to make
selected text act as a hyperlink, and other actions.

When you work with a WYSIWYG editor like Composer, all those codes that
make a text document work like a webpage are happening behind the scenes.
Select a word, click  the italics button, for instance, on the formatting
toolbar, and the html document in the background adds code like:
<i>word</i>. On the webpage, your word looks like word.

Getting Started

There are a number of ways to start or open a page in Composer. The following
are four common methods. Depending your type of activity, one may be more
efficient or appropriate than another.

Method One (Starting with a Blank Web Page):

1. Start Netscape Communicator (via desktop icon or
menu)

2. Click on the Communicator menu
3. Select Composer from the menu

Composer will open with a blank page.

Method Two (Starting with a Blank Web Page):

1. Start Netscape
Communicator (via
desktop icon or menu)

2. Click on the File menu
3. Select New
4. Select Blank Page
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Method Three (Opening an Existing Web Page):

1. Click on the File menu
2. Select Open page

3. In the Open Page window, click on the Composer radio button

4. Either type the path to the web
page file you wish to open OR
click the Choose File button
and browse to the location of
the file.

Method Four (Viewing a page and switching to Edit Mode):
With Netscape Navigator running:
1. Surf to the page you wish to work on
2. Click on the File menu
3. Click on Edit Page
The page will open in Composer.

Notes about Edit Mode:
You may use this to edit ANY page on the web, not
just pages you have saved to disk or server.
However, you will only be able to save (or publish) the
page to drives to which you have "write" access.

Composer Tools (Overview)

The tools available to designers are displayed at the top of the Composer
window. The illustration below shows that these tools are broken into three rows
or bars:

Top: Menu Bar        Middle: Composition Toolbar        Bottom: Formatting Toolbar

The Composition and Formatting toolbars contain function buttons for the most
popular actions. All the toolbar functions and much more are available from the
regular menus as well. As you can tell, the items on the Formatting Toolbar are
very similar to what can be found on most word processing programs.
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Explanation of the tool buttons on middle (Composition) bar:
New: Starts a new blank web page
Open: Opens an Existing Web Page
Save: Saves the page to a local or network drive
Publish: FTP's the page to a remote server
Preview: Opens the current page in Navigator
Cut: Removes selected text or other element to the clipboard
Copy: Copies selected text or other element to the clipboard
Paste: Inserts cut or copied elements into the page from the clipboard
Print: Prints the current page (in browser format)
Find: Locates words or phrases within the page
Link: Creates hyperlink from a word or graphic to another page or a target
within the same page
Target: Marks a spot within a page as a something to be linked to
Image: Inserts an image into the current page
H. Line: Inserts a horizontal rule
Table: Specifies table layout and inserts table
Spelling: Checks spelling or text in current page

Holding the mouse over any of these tool
buttons will display the button's purpose.

Creating a basic web page: Employee Home Page

With Composer on screen, we can create a basic web page much as we might a
word processing document. We can of course also open any existing web page
and make modifications.

Many of the following exercises use the example of a basic home page to
demonstrate the creation of typical web page elements.

Starting with a blank Composer page, left click in the main window and type the
following:

John Smith
Professor of Webology
Office: 4602
Phone: 635-9876
Email: jsmith@oakton.edu
Department of Computer Stuff
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Note1: If you already have text typed in another document, you can open
that document, select & copy the text, and paste it into the blank
composer page.
Note 2: See also instructions for saving Word 97 document as web pages.

Once there have text in the Composer page we can begin to format it. Select any
text you wish to change by dragging the mouse across the word(s) to highlight.
(If you make any of the following changes and wish to undo it, click on the edit
menu and select undo.)

Following are some of the basic text formatting actions

To Change the Text Font:
1. Select the desired text
2. Click on the down arrow of the font menu
3. Scroll to the desired Font name
4. Click on the Font name

To Change the Text Size
1. Select the desired text
2. Click on the down arrow of the size menu
3. Scroll to the desired text size
4. Click on the desired  text size

Note: You may also click in the top box (where it reads "12" in
the illustration to the right) and type in the desired size.

To Change the Text Color
1. Select the desired text
2. Click on the down arrow of the color menu. This will

produce a pallet of basic colors
3. Click on the desired color

Note: When you create a hyperlink, the text will by
default be blue. To avoid confusion, avoid blue text
unless it is a hyperlink.
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To Change the text style:
1. Select the desired text
2. Click on one of the style buttons on the formatting toolbar

(Bold, Italics, Underline)

Note 1: Alternately, you could click on the Format menu, select Style, and
choose from such additional styles as strikethrough and superscript
Note 2: Because this is a web page, you should avoid using underlining.
Users expect underlined text to be hyperlinks. When you create a link, the
text will generally be underlined for you.

To Change Text Alignment
At the right end of the formatting toolbar are three alignment
buttons: Decrease Indent, Increase Indent, and a drop menu
for Right Justify, Left Justify, and Center.

1. Select the desired block of text
2. Click on the appropriate button.

Importing Graphics
Composer allows you to add graphics to your web page. These graphics can
reside in the same folder with your page when you save it or they can be called
from another location (local or elsewhere on the web).  Acceptable image formats
have the file extensions .jpg or .gif.

To Import a graphic:
1. Click on the Image button on the toolbar

2. Type the name of the image file in the Image Location field.
Or
Click on Choose File and
browse to the name of
the image file
Or
Type a web URL for the
image.

Note: Selecting Leave
Image at the Original
Location means that
when you save your web
page, the image file will
not be downloaded to
the same directory as
the HTML file.
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Additional options to consider:
• Entering in the dimensions of an image is said to speed the loading time of

the page. The difference may be negligible.

• Alt Text/LowRes Button. Alt text is short, descriptive text like "PICTURE OF A
PUPPY" that will show while an image is loading in a browser (or if an image
fails to load). This is a considerate action for people with slow connections as
well as some specialized browsers.  LowRes images are generally smaller file
size versions of the original image that will load first while the main version of
the image is still loading.

Background Images, Colors, and Page Properties
Composer does not automatically assign a background color or image to a web
page.

In fact, even the white background that appears to be called for is really only a
Netscape display default. Unless you call for a white or other colored
background, some browsers will display the page with a gray background.

You can add either an RGB color code or a specific graphic to dress up the
appearance of your page. Background images are generally jpeg (.jpg) or .gif
graphics. These images can be set to take up the entire background or be tiled
(multiple copies of the same image).

Solid color backgrounds are the result of an RGB color code placed in the page's
HTML. Similarly, image backgrounds result from placing code calling for a
specific image in the body code.

Browsers have default colors for text, generally black for normal text, blue for
links, and purple for links to pages that you've already been to. These defaults
are not part of the HTML code and will be overridden when you select other
colors (which will be part of the code).

 Composer makes inputting your choices for page colors and properties as easy
as picking from a menu. In fact you are picking from a menu.
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To Input Backgrounds and Text Colors
1. Click on the Format menu
2. Click on Page Colors and Properties
3. This will bring up the Page Properties dialogue

window

The Page Properties Window
is where you select colors or
input the names of background
images.

The upper part of the window
shows the main elements that
are available for the designer
to change.

Clicking on a button to the left
of the type of text will drop
down a color palette from
which to choose.

The Color Schemes drop menu
has several color combinations
available which will change all
the page colors at once.

The lower part has a text field where you can enter the name of a background
image. Here you can type in or browse to an image file. You can also type in the
URL for an image on the web.

Unless you select "Leave Image… " Composer will save a copy of the chosen
image into the same folder that your page is saved to.

Creating Links
Any element on a web page can be used to create a hyper link. Basic links are
frequently made using text or simple images.
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To create a text link:
1. Select the text you wish to be a

link by dragging the cursor
across it.

2. Click on the link icon on the toolbar.
A dialogue window will appear.

3. Type in the URL for the page to
be linked
(see also document on Relative
vs. Absolute URL's)

4. Click OK

5. The text you selected should
now appear as a blue underlined
font.

Mailto: Links
It is standard on any type of web page to have a name and email address so
people know how to contact the author. It is considerate to make the name
and/or address a "mailto:" link. When you click on a mailto: link, an email
composition window pops up with the email address already in the To: field.

To create a mailto: link:
1. In the page, select the name or address for the

link by dragging the mouse across it.

2. Click on the link button on the toolbar

3. In the Link To field, type:
mailto:<your email address>
See example Ü

4. Click OK.
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Image Links
Images can be links as well. The simplest image link is essentially "One
Image/One Link." Clicking anywhere on such and image will take you to another
location. A single image can also be used as an "image map," wherein specific
areas of the image link to different URL's.

An example of using a single graphic as an image map is the navigation bar
found on many Oakton web pages:

HTML code is used to identify coordinates of the image. Image maps can most
easily be created with special programs such as MapEdit.

To Create a Simple Image Link
1. Click once on the image to be linked
2. Click on the link icon on the toolbar
3. This will pop up an Image Properties dialogue window similar to the one for

the text link in the previous steps.
4. Type in the URL for the page to be linked.
5. Click OK

Editing HTML
At some point, as convenient as WYSIWYG editing is, you may feel you just
have to dig into the HTML code. This may frequently occur when editing a page
originally created with another program. Composer allows you to do this with a
popup HTML editor window. This window shows the actual html code behind the
WYSIWYG web page and allows you to alter it.

To bring up the editor window:
1. Click on the Tools menu

2. Select HTML Tools, then Edit
HTML Source. After a moment,
the edit window will appear.
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The HTML Edit Window floats
in front of the Composer
screen. After you make a
change to the code, click the
Apply button to see how the
changes affect the page.

If you're satisfied with the
changes, click OK. To undo
(all) changes, click the Cancel
button.

Note 1: You will not be able
to work in the WYSIWYG
window while the editor window is open.

Note 2: The Edit HTML window will open faster the next time in the session that
you bring it up so don't be reluctant to close it.


