Web Pages Made Easy

With

Adobe Dreamweaver
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Part 2 * : Intermediate Skills

· Creating and Defining a Web Site
· Using Page Templates
· Layers/tables
· Word Conversion
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* Com
*combine with Part 1, Intro to Dreamweaver for the “Intro to Dreamweaver with Templates” workshop
Dann Foster

Information Technology Department

Oakton Community College

Fall 2008

Section I: Intro

Macromedia Dreamweaver (DW) is a very powerful and sophisticated yet intuitively designed web authoring program.  One of its best assets is the way new users can begin using it productively almost immediately, adding skills and learning new concepts as needed or desired.

In the introductory session, we covered the basic tools and screen layout. We introduced the core features and used them to create a basic personal home page. In this intermediate session we will apply some of the more sophisticated features, features that separate programs like Dreamweaver from simpler programs such as Netscape Composer.

Anyone who attended earlier workshops using Dreamweaver version 3.0 or MX, should not have difficulties moving to Dreamweaver CS3. Skills acquired in earlier versions should transfer easily.  DW CS3 offers many more high-end features and, to an extent, better integrates them with the basics. 

Many of the materials included in this document are from the Macromedia online support pages at http://www.adobe.com/support/dreamweaver/  .

Goals and Objectives 

The target learner for this material has the following entry characteristics:

· Can demonstrate familiarity with the basic layout and essential functions of Dreamweaver by creating a simple home page with text, table, and graphics.

· Has some experience with simple web page authoring 

· Can function comfortably in a networked Windows environment

· Understands web page saving/storing at Oakton

· Has a basic knowledge of HTML markup concepts

This document is intended to introduce learners to 

· Creating and defining a web site

· Creating a template

Upon completion, the learner will be able to create a simple web site which links multiple, template-based pages. 

Starting Dreamweaver on Oakton's network (in XP)

1. Click the Start menu (lower left corner of computer desktop)

2. Click on All Programs

3. Click on NAL 

4. Click on Graphics Software OR Internet Software

5. Click on Web Design

6. Click on Adobe Dreamweaver CS3
Note: You may also launch a browser at this time.

The first time you launch Dreamweaver on a particular computer you mush choose the workspace setup. (You may change it later under Edit Menu > Preferences > General > Change Workspace.)

1. For this workshop, choose “Designer”

2. Click OK. 
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Section II: Creating/defining a Web Site

Definition from Macromedia: "A Web site is a collection of related HTML files (and dependent files such as images and animation) that you make available on a Web server for people to view. You can use Dreamweaver to build your site on your computer and then transfer it to a server, or remote site."

A little more info:  
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A large web site can consist of multiple sub-sites, each of which consists of related pages and files. Oakton hosts numerous sub-sites where the pages within the sub-site closely resemble each other AND reflect to a degree the look and navigational structure of the larger overall Oakton site. 

· As a rule, a site or a sub-site branches various web pages off from a single main page, generally referred to as the "home page" or "index page" and conventionally named "index.html." 

· A faculty web site might consist of an index page which introduces the instructor and which links off to additional pages such as syllabi and other class materials (pages of personal interest are also allowed).

· While a page in a web site may link to a page on another web site or web server, that outside page is not considered part of the web site. 

Oakton employees may create their own web sites in their public.www folders under their H: drives.  Pages stored here may be edited directly (open page from the H:drive, edit, save—page is now updated). However, it is far more typical to create a "local" site on a hard drive, floppy or other storage medium and, when the pages are ready for display, post them to the "remote" site.  The locally stored copy of the site will exactly mirror the directory structure of the pages on the remote server.
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Creating a Site

1. Open the Site menu

2. Click Manage Sites…
The Manage Sites window will appear.
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3. In Manage Sites, Click New 
A popup menu will appear.
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4. Click Site on the popup menu.
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The Site Definition dialog window will appear.
This is where the properties of the site are set. There are two ways to work through definitions: Basic and Advanced. Basic walks users through the process step by step. Advanced allows users to fill in properties or leave blank, as desired. It’s not necessary to complete all definitions at the beginning. Some items can be decided later or ignored indefinitely.
6. Click the Advanced tab.

7. A menu of definition categories is on the left side of the screen. These are all the types of information that may be filled in when creating or editing (revising later) the site.
Defining the Site
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Local Info

1. Choose Local Info from the Category list.

2. Type a name in the Site Name field 

· The name can be whatever you want and can be changed later.

3. The Local Root Folder: will default to your My Documents area. Type a name for a subfolder after “My Documents\”.  A subfolder by this name will be created when you complete Local Info.

4. Default Images Folder is optional. If you’re planning a lot of images, type a name for the folder in this field and it will be created.

5. In the HTTP Address field, enter the actual URL of your site. 

· For Oakton personal sites, this would be something like http://www.oakton.edu/~username/
· You can fill this in later, if desired.
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Remote Info

This is how you tell Dreamweaver to move files from the local site to their ultimate location on the web (once you are ready to move them there). If you are working on-campus, you can choose either FTP or Local/Network. It's alright to leave this as "None" until you are ready to move files. 

When you are ready to input settings, proper settings will look something like one of these (you can only set up one method but you can change your mind and set up a different one at any time):

FTP:
· [image: image26.png]Remote Info
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Host is ftp.oakton.edu
· Host Directory is going to be something like home1/users/jsmith
· Login is your standard Oakton login ID

· Password is your standard Oakton password

· Choose Passive FTP

· It’s your choice whether to automatically upload files when saving them after editing

· Check and check out is probably not necessary unless you are sharing file editing tasks with other people
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Local/Network

· When working on campus, and you are mapped to the H:\public.www directory, you can choose Local/Network as the preferred means of transferring files.

Other Site Definitions:
Testing Server
· Skip

Cloaking
· Skip

Design Notes
· Skip

Site Map Layout
· We’ll get to this after we create a home page. See end of document.
File View Columns

· Skip 
Contribute

· Skip

(Most Oakton users won’t need to define these things)
When finished with setting Local and Remote info, Click OK.

Section III: Page Templates and "Content Management"

The idea of a "template" is to achieve consistent appearance from page to page by basing all pages off a single layout. Part of each page would stay the same and other parts (content specific to the purpose of the page) would vary. This basic concept dates way, way back to the early days of the Web.
In those early days, the template concept worked like this:

· Open an existing page in your favorite web authoring software

· Change it to include new stuff

· Save it under a new file name

· Rinse

· Repeat

Because the code of the original was right there and easy to change by the web author, such templates didn't completely protect and lock in the layout. An inadvertent keystroke or line break here or there could throw off much of the appearance. As maintaining web sites became the work of large teams, avoiding layout variations became a greater concern. Thus the concept of Content Management software is born: separate the content, the information elements specific to a particular page, from the frame of shared graphical and navigational elements. The line drawn between the two-- what will and will not vary between pages-- is up to the author of the template. 

Dreamweaver handles this by creating a template "page" that is never seen on the web. Rather, it is stored in a separate directory and the pages you do see are coded to call elements from it. The template is laid out as editable and non-editable areas. Pages based on the template cannot alter the locked (non-editable) areas. Locked areas can only be changed on the template and thus will affect all the pages based on that template.

Creating a Template 

Templates can be created using an existing page or starting a new page. The process is about the same. Key is making a few decisions beforehand:

· What pages will be based on the template?

· What elements (text, navigation, graphics) can a group of pages share?

Creating a completely new template

1. From the File menu, choose New
The New Document window will open

2. On the New Document window, choose Blank Template from the Category column.
3. Choose HTML template from the Template Type column.

4. In the Layout column, for this workshop, choose “<none>.”

· Dreamweaver CS3 provides a number of typical layout choices. These choices use style sheet code to set up common page designs involving multiple columns either fixed (locked dimensions) or elastic.

· If you were to try this exercise using one of the provided layouts, you would probably use “2 column elastic, left sidebar, header and footer”

5. Click Create
6. Begin laying out the elements of the template page. (See Exercise: Building the Template below)
Creating a Template from an Existing page

1. From the File menu, choose Open

2. Open an existing page you wish to model a template on.

3. From the File menu, chose Save As Template

4. Name the template something to distinguish it for use later.

5. Make changes to the template (See Exercise: Building the Template)

6. If desired, apply the template to the old, original page. 
a. Open old page 

b. Open Modify Menu

c. Choose Templates > Apply Template to page
NOTE: You can use more than one template on a single site. You might want to use 2 or more similar templates in a site if you have 2 or more significantly different groups of pages. 
Exercise: Building the template

Typically, a template will contain shared graphics and navigational links. For this exercise, we will insert a logo image, a table with some color, a column of links, and some text for the footer.


Creating the Template Page

(Complete “Creating a Completely New Template” above)

1. Click the Table icon

2. Insert a 3 column by 3 row table with 0 border.



	1. 
	2. 
	3. 

	4. 
	5. 
	6. 

	7. 
	8. 
	9. 


3.  Merge the following cells 
· 2&3

· 4&7 
· 8 & 9
4. Download the logo image from http://www.oakton.edu/~dannf/homefiles/oakton_logo.jpg
5. Download a portrait placeholder image from http://www.oakton.edu/user/~dannf/homefiles/mugshots/
**Save images to the local folder where your web files are stored**
6. Click to place cursor in Cell 1

7. Change the background color to a soft color that will allow maximum contrast with black or dark text.
8. Repeat for (merged) cells 2-3 and 4-7

9. Click to place cursor in Cell 1 (again)

10. Click the Insert Image icon

10. Locate and select oakton_logo.jpg

11. Click OK

12. Click to place cursor in Cell 5

13. Click the Insert Image icon

14. Locate and select the “mugshot” downloaded (from step 5)

15. Setting Cell Alignments:
On the properties panel, open the Vertical menu and choose Top.
This will align text and other objects at the top of the cell.

16. Repeat vertical alignment set for all other desired cells
ALT: You can drag the mouse from one corner of the table to the opposite corner so all cells are selected then choose Top from the Vertical menu to assign that alignment to the entire table.

17. Type in the name and contact info as shown on illustration on page 8 into Cell 6.
18. Type in the Header (“Faculty Home Page” & 3 Universal Links) into merged cells 2 & 3

19. Type the Footer text (“Last Update,” contact info, etc.) as shown on illustration on page 8 below the table.
DECLARE EDITABLE REGIONS

In order to build multiple pages off this one template, one or more areas of the template page must be declared “editable.” The editable regions are where the varying copy on template-based pages will be inserted. All other areas by default will be uneditable and will not vary from page to page.


To Set an Editable Region
1. Click the mouse in merged cells 8 & 9
2. Click the Insert Menu

3. Choose Template Objects

4. Choose Editable Region


5. The New Editable Region dialog window appears.

6. Type a name for the region.
You can have multiple editable regions on a template. Each needs to be named primarily because later on you may wish to apply the template to an existing page. Dreamweaver will ask you which editable regions should receive content from the old page.
7. Name the region for cells 8&9 something like “MainContent.”

8. Click OK

9. Repeat inserting an editable region for merged cells 4&7. Name this region something like “MenuBar”
Each editable region will look something like the one illustrated here. The name of the region will appear in a tab over a content area that temporarily also contains the name of the region. When you build a page off the template later, you will insert text and other elements into this content area.


Add text to the menu bar’s editable region
Following the example on page 8, create headings and a bulleted list. (see pages 13 and 14 of Dreamweaver intro)

Add background color to merged cells 2&3 and 4&7 if if desired.

(see page 11 of Dreamweaver intro)

NOTE on Your Two Editable Regions
Your MenuBar region has text and links in it that will appear when you create a new page from this template. However, because it is editable, you can alter the menu on any individual  page, as appropriate.

Your MainContent Region is empty in the template in order to always begin a new template-based page with an empty space for new content (which will always be different from page to page across your site). 

SAVE TEMPLATE

1. Click the File Menu

2. Choose Save As Template
The Template dialog window will open.

3. Type in a name for the template.
Choose an appropriate and memorable filename so you’ll know what template to use later.

4. Click Save.

CREATE A NEW PAGE FROM TEMPLATE

As you add pages to a web site you’ll probably want to create them from a standard template then make changes to the new page such as inserting content (text, images, links, etc.) unique to that sub-page.

To create a page from an existing template:

1. Open the File menu

2. Choose New 
The New Document dialog opens

3. Click Page from Template in the far left column
4. Click the name of the site you are working on in the second-to-the-left column
5. Choose the name of the desired template (remember one site can use many templates)
6. Check the “Update” box in the lower right so when you later update the template, the page you create now will reflect your template changes.

7. Click Create.
A page based on the template should open and you can begin working in the editable regions.

Adding content to the template-based page
You can only add content to the designated editable region. This region will expand to contain whatever text or other content you type or paste into it.

1. Click in the editable region

2. Begin typing or pasting content.

Applying an existing template to an existing page

Sometimes a template may be created to dress up or frame a series of existing pages. Such pages essentially are inserted into an editable region of the template. In our John Smith example, another entire web page could be inserted into the Content1 region.

Pages do not need to reside in the same web site as the template being applied.

To apply a template to an existing page

1. Open the desired existing page.


2. From the Modify menu, choose Templates > Apply Template to Page

3. Choose the desired template from the dialog window menu

4. Click Select.

5. Choose the editable region (of the template being applied) where the existing page's content will be inserted.

· In the illustration, the entire contents of a page (Document Body) would be dropped into editable region of the template named “content1.”
· The other possible choices for target regions are date and doctitle (neither would be appropriate for general content of a web page.

· The choice of "Nowhere" removes the content. 

6. Click OK. 

Undoing a Template

If you just applied a template to a page you can use the regular Edit>Undo function.

Any template-based page can be separated at any time from the template this way: 

1. Open the page

2. Go to the Modify menu > Templates > Detach from Template

· Detaching from the Template will leave the template's elements in place BUT there will be no locked regions. Changes made to the formerly locked regions will not affect the template or other pages based on the template.

(Return with us now to…) Site Management: Map View
The Site Management window opens on the Files tab running along the right side of the Dreamweaver window. 

After you have created the page you intend to be your site’s homepage (and likely named it “index.htm”) you can define the Map View. The map view shows how all the pages and other elements in a site relate and link to one another, much like a flowchart. 
To view a “map” you must set a home page—that is, declare one of your existing pages to be the top page of the site. 


If you have a home page declared,  

expand the menu as shown and select Map View

To set a home page

1. Open the Site menu on the main menu bar

2. Choose Manage Sites from the menu

3. The Manage Sites window appears.

4. Choose your site 

5. Click Edit.

6. The Site Definition dialog opens 
7. Choose Site Map Layout if it doesn’t open to that. 

8. In the Home Page text field, type the homepage filename 
or
Click the yellow folder and search for the filename.

9. Click OK to close the Site Definition window

10. Click Done to close the Manage Sites window.
(simple site diagram)





Home Page:


http://servercc.oakton.edu/~jsmith/index.html





syllabus101.htm





syllabus173.html





prolinks.html





otherstuff.htm





Type or paste content in this area





REFER TO �DREAMWEAVER INTRO  FOR PAGE BUILDING INSTRUCTIONS.








Updated (yet again) for Dreamweaver CS3
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