Web Pages Made Easy

(and cooler)

With

Macromedia Dreamweaver
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Part 2: Intermediate Skills

· Creating and Defining a Web Site
· Using Page Templates
· Layers/tables
· Word Conversion
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Dann Foster

Information Technology Department

Oakton Community College

Section I: Intro

Macromedia Dreamweaver is a very powerful and sophisticated yet intuitively designed web authoring program.  One of its best assets is the way new users can begin using it productively almost immediately, adding skills and learning new concepts as needed or desired.

In the introductory session, we covered the basic tools and screen layout. We introduced the core features and used them to create a basic personal home page. In this intermediate session we will apply some of the more sophisticated features, features that separate programs like Dreamweaver from simpler programs such as Netscape Composer.

Anyone who attended earlier workshops using Dreamweaver version 3.0, should not have difficulties moving to  Dreamweaver MX. Skills acquired in 3.0 should transfer easily.  MX offers many more high end features and, to an extent, better integrates them with the basics. 

Many of the materials included in this document are from the Macromedia online support pages at http://www.macromedia.com/support/dreamweaver/ .

Goals and Objectives 

The target learner for this material has the following entry characteristics:

· Can demonstrate familiarity with the basic layout and essential functions of Dreamweaver by creating a simple home page with text, table, and graphics.

· Has some experience with simple web page authoring 

· Can function comfortably in a networked Windows environment

· Understands web page saving/storing at Oakton

· Has a basic knowledge of HTML markup concepts

This document is intended to introduce learners to 

· Creating and defining a web site

· Creating a template

Upon completion, the learner will be able to create a simple web site which links multiple, template-based pages. 

Starting Dreamweaver on Oakton's network

1. Click the Start menu (lower left corner of computer desktop)

2. Click on NAL 

3. Click on Internet Software

4. Click on Web Design

5. Click on Macromedia Dreamweaver MX
6. Choose “Classic Layout” if prompted. (This will better allow for isolating some of the tools needed for the workshop)

Note: You may also launch Netscape at this time.

Section II: Creating/defining a Web Site

Definition from Macromedia: " A Web site is a collection of related HTML files (and dependent files such as images and animation) that you make available on a Web server for people to view. You can use Dreamweaver to build your site on your computer and then transfer it to a server, or remote site."

A little more info:  
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A large web site can consist of multiple sub-sites, each of which consists of related pages and files. Oakton hosts numerous sub-sites, such as ISS, where the pages within the ISS sub-site closely resemble each other AND reflect to a degree the look and navigational structure of the larger overall Oakton site. 

· As a rule, a site or a sub-site branches various web pages off from a single main page, generally referred to as the "home page" or "index page" and conventionally named "index.html." 

· A faculty web site might consist of an index page which introduces the instructor and which links off to additional pages such as syllabi and other class materials (pages of personal interest are also allowed).

· While a page in a web site may link to a page on another web site or web server, that outside page is not considered part of the web site. 

Oakton employees may create their own web sites in their public.www folders under their H: drives.  Pages stored here may be edited directly. However, it is far more typical to create a "local" site on a hard drive, floppy or other storage medium and, when the pages are ready for display, post them to the "remote" site.  The locally stored copy of the site will exactly mirror the directory structure of the pages on the remote server.

Dreamweaver recommends following such a local/remote method, which is the method we will use here.

Key Settings

Creating a "root folder" for the new site

1. Start My Computer or other file management software

2. Locate your home directory (H: drive).

· Note: H: is chosen for purposes of the workshop. When working on your own, where you save your local files is your own choice.

3. Create a new folder on H: called "HomeSite" 

· All files for your site will go into the HomeSite folder. Note that these two folder names were arbitrarily chosen. 

Creating an Index page

1. In Dreamweaver, save the currently open page as "index.html" into the HomeSite folder 

OR

Copy an existing page into the HomeSite folder
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Defining the Site

1. Click Site Menu > New Site
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2. Choose Local Info from the Category list.

3. Type a name in the Site Name field 

· The name can be whatever you want and can be changed later.

4. The Local Root Folder: This is the folder on H: we named "HomeSite." You can click on the yellow folder icon to find it.

5. In the HTTP Address field, enter the actual URL of your site. 

· You can fill this in later.

· For Oakton personal sites, this would be something like http://servercc.oakton.edu/~username/
Other Category settings
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The other choices in the Category list are less critical upfront than Local Info but will become more important as you proceed in developing your site and individual pages.

Remote Info

This is how you tell DreamWeaver to move files from the local site to their ultimate location on the web (once you are ready to move them there). If you are working on-campus, you can choose either FTP or Local/Network. It's alright to leave this as "None" until you are ready to move files. When you are ready, proper settings will look something like these:
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FTP:
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· Local/Network

Application Server

(Leave set as "None."  If you should need to re-set in the future, contact the Oakton Webmaster for settings advice.)

Design Notes

Design notes are useful when working as a team on a single site. It allow you to save notes about the site or its pages for other team members to reference. But, as with any other team project, never expect anyone to actually read your directions.

The final two categories determine how you will look at your site and how its page files relate to one another. You can toggle between a Site Map view (sort of a 'flow chart' view) and the File View (much like the 'detailed view' in My Computer).
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Site Map Layout

· Click on the yellow folder icon and find your local site's index page (for this workshop, the field should be filled in as shown).

· You may wish to check "Page Titles" for the Icon Labels if you have given each of the pages on your site a unique and distinctive name.

File View Columns
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Here you set what types of information you want to clutter your screen with in the File View. Generally speaking you want to keep the defaults. That will provide you with the following information about EACH file in the web site:

· File name

· Last modified date

· File type (HTML, image, etc.)

· File size

· Notes associated with the file (if any)

· Check out information (file is in use by a team member)

Your options are mainly to add or delete columns and to change the text alignment. 

When finished choosing the Category Settings, Click OK to close the Define Sites dialog. 

The Site Window will appear. In the illustration here, a second file named "syllabus.htm" has been added to the site. Index.html contains a link to syllabus.

The illustration shows 

1. how (left panel) the two files navigationally relate to each other, and 

2. (right panel) the list of files in the folder with the size/type/etc. information that was set under the File View category.

Editing Pages in a web site.

Now that your web site has been defined, you may want to begin editing pages like this:

1. Launch Dreamweaver

2. Go to the Site Menu

3. Choose Open Site 

4. Choose the site you wish to open 

5. When the site window opens, double click on the desired page's file name.

Section III: Page Templates and "Content Management"

The idea of a "template" is to achieve consistent appearance from page to page by basing all pages off a single layout. Part of each page would stay the same and other parts (content specific to the purpose of the page) would vary. This concept dates way, way back to the early days of the Web (May 7-23, 1996). 

In those early days, the template concept worked like this:

· Open an existing page in your favorite web authoring software

· Change it to include new stuff

· Save it under a new file name

· Rinse

· Repeat

Because the code of the original was right there and easy to change by the web author, such templates didn't completely protect and lock in the layout. An inadvertent  keystroke or line break here or there could throw off much of the appearance. As maintaining web sites became the work of large teams, avoiding layout variations became a greater concern. Thus the concept of Content Management software is born: separate the content, the information elements specific to a particular page, from the frame of shared graphical and navigational elements. The line drawn between the two-- what will and will not vary between pages-- is up to the author of the template. 

Dreamweaver handles this by creating a template "page" that is never seen on the web. Rather, it is stored in a separate directory and the pages you do see are coded to call elements from it. The template is laid out as editable and non-editable areas. Pages based on the template cannot alter the locked (non-editable) areas. Locked areas can only be changed on the template and thus will affect all the pages based on that template.

Creating a Template (New and Existing)

Templates can be created using an existing page or starting a new page. The process is about the same. Key is making a few decisions beforehand:

· What pages will be based on the template?

· What elements (text, navigation, graphics) can a group of pages share?

Creating a new template

There are several ways to start a new template. Follows are the simpler ways for new users.

Both methods should be done after defining your site. 
Method 1

1. From the File menu, chose New to launch a normal blank page
2. From the File menu, choose Save As Template.
3. Save template to the folder that contains the site you will be working on.

Method 2

1. (Launch Assets panel from the Windows menu if it’s not already open)
2. On the Assets panel click the Templates icon 


3. Click the New Templates icon at the bottom of the Assets panel

4. Type a name for the template to replace “Untitled” (If you accidently unselected the file name, right-click on it and choose Rename from the pop-up menu.)

5. Double click on the template name to open it for editing.
Opening an Existing Template

While your template should be immediately available (and visible) for editing upon its creation, you may follow these steps to re-open it for later editing.
Method 1:

1. Open the Site Map or Site Files window for the site which contains the desired template
2. Expand the Templates folder in the right pane

3. Double-click on the name of the desired template

· The template will appear in the Dreamweaver Document window for editing.

Method 2:

1. From any window’s File menu, click Open

2. Use normal Windows dialog windows to locate the desired template (look in the templates folder of the correct site folder
Method 3 

1. Open a regular web page that is based on the desired template.

2. From that page's Modify menu, choose Templates and then Open Attached Template.

· The template that controls the page will open. 

· This method is especially helpful when you are working on a template-based page and find that you need to change an uneditable region. 

Building & Modifying a Template

With a blank template open, you can now create or edit the elements that will appear on all pages based on it.

Exercise: Elements of the template

Typically, a template will contain shared graphics and navigational links. For this exercise, we will insert a header image (save to your web site local root folder: http://servercc.oakton.edu/~dannf/occ-red2.gif), a table. a column of links, and some text for the footer.

1. Click Insert menu > Image 

2. Choose occ-red2.gif

3. Click OK

4. Type "John Smith's Web Site" next to the image.

5. Insert a 1-row, 2-column table below image

6. Type some links in the left column

7. Insert a horizontal rule below the table.

8. Type "Last update" and an email link below the horizontal line.

Defining a template's editable regions

The default for a new template is for all regions to be "locked," uneditable. Creating a page based on such a template would not allow the author to insert additional material.

So, for a template to do anyone any good, some regions must be set as "editable." It is the "editable" regions where new material will be inserted . 

For this exercise we will create 2 editable regions on the template.

To set editable regions:

1. Click anywhere (for exercise: in the right column of the table.)
2. Click the Modify menu

3. Choose Templates Objects > Editable Region


4. Type a short, descriptive name for the region in the dialog window that appears.

5. Click OK.


6. Markup designations like that shown here will appear in the right column of the table. 


· Pages based on this template will allow for new material to be inserted in the right column of the table only.

7. Find the "Last update" text below the horizontal rule.

8. Select the date only, as shown.

9. Click the Modify menu

10. Choose Templates > New Editable Region


11. Type a short, descriptive name for the region in the dialog window that appears.

12. Click OK.


13. Markup code should surround the date only. Pages based on this template will allow the author to change the date 

· (A script to change the date automatically could also be added-- either to the template or to the page based on the template.)

Creating Documents Based on Existing Templates

Once the template is created and saved, other web pages can be based on it. Authors can either start a new template-based page or apply a template to an existing page.

To start a new page:

1. (From any Dreamweaver Document window) Click on File menu > New 

2. In the new page dialog window, slick the templates tab near the upper right.
3. Choose the desired template from the Templates list.

4. Click Select.

5. A new document window will appear.

6. Authors may change only the areas marked as editable-- in this case "Content1" and "date." These fields will expand to accommodate virtually any amount of text (typed in or pasted in)

7. In this example, the table was not assigned specific column widths in the template file. Such values can be set to limit changes in text placement on other pages.

8. By default, authors can change the text in the Title field (top of window)

Note: To re-lock an editable region, return to the template and choose Templates > Remove Editable Region from the Modify menu. Select the name of the region from the popup dialog and click OK.

Applying an existing template to an existing page

Sometimes a template may be created to dress up or frame a series of existing pages. Such pages essentially are inserted into an editable region of the template. In our John Smith example, another entire web page could be inserted into the Content1 region.

Pages do not need to reside in the same web site as the template being applied.

To apply a template to an existing page

1. Open the desired existing page.


2. From the Modify menu, choose Templates > Apply Template to Page

3. Choose the desired template from the dialog window menu

4. Click Select.


5. Choose the editable region (of the template being applied) where the existing page's content will be inserted.

· In the illustration, the entire contents of a page (Document Body) would be dropped into editable region of the template named “content1.”
· The other possible choices for target regions are date and doctitle (neither would be appropriate for general content of a web page.

· The choice of "Nowhere" removes the content. 

6. Click OK. 

Changing your mind - A template's undoing

There are times when you'll want to undo a template application or disconnect from a template. There are a number of ways to do this, depending on how far along in the process you are.

1. Undo. Right after applying a template to an existing page you can go to the Edit menu and click on Undo. Dreamweaver records recent actions so you can 'undo' your way back through each.

2. Detach. Whether a document was created new using a template or had a template applied to it, the template can be detached.

· Go to Modify > Templates > Detach from Template.

· Detaching from the Template will leave the template's elements in place BUT there will be no locked regions. Changes made to the formerly locked regions will not affect the template or other pages based on the template.

(simple site diagram)
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